stage1_2/Makefile.am
changeset 881 e05d69c1ccb3
parent 871 878e9bf4c6ec
child 1015 9414b0785849
--- a/stage1_2/Makefile.am	Wed Mar 19 12:13:43 2014 +0000
+++ b/stage1_2/Makefile.am	Thu Mar 20 10:29:39 2014 +0100
@@ -5,12 +5,15 @@
 
 # Make sure this header file is generated first (by bison), as it is included
 # by other C++ code that will also be compiled.
-BUILT_SOURCES = iec_bison.h
+BUILT_SOURCES = iec_bison.hh
+
+%.hh: %.h
+	cp $< $@
 
 CLEANFILES = \
 	iec_flex.cc \
 	iec_bison.cc \
-	iec_bison.h
+	iec_bison.hh
 
 lib_LIBRARIES = libstage1_2.a
 libstage1_2_a_SOURCES = \
@@ -19,5 +22,5 @@
     create_enumtype_conversion_functions.cc \
 	stage1_2.cc 
 
-libstage1_2_a_CPPFLAGS =  -DDEFAULT_LIBDIR='"lib"' -I../../absyntax -DYY_BUF_SIZE=65536
+libstage1_2_a_CPPFLAGS =  -DDEFAULT_LIBDIR='"lib"' -I../../absyntax -DYY_BUF_SIZE=65536 -fpermissive