debian/rules
changeset 171 59f5197b088a
parent 106 0fff950e578e
child 213 f386d870e8e4
equal deleted inserted replaced
170:e10fbd3707df 171:59f5197b088a
    15 	CFLAGS += -O0
    15 	CFLAGS += -O0
    16 else
    16 else
    17 	CFLAGS += -O2
    17 	CFLAGS += -O2
    18 endif
    18 endif
    19 
    19 
    20 configure: configure-stamp
       
    21 configure-stamp:
       
    22 	dh_testdir
       
    23 	# Add here commands to configure the package.
       
    24 
       
    25 	touch configure-stamp
       
    26 
       
    27 ##############
       
    28 # And now the simple things for dpatch. Here we only apply/unapply the patches.
       
    29 # You can do more things with dpatch, like having patches only applied on
       
    30 # a special architecture - see the non-dh version of the sample for this!
       
    31 patch: patch-stamp
       
    32 patch-stamp:
       
    33 	dpatch apply-all
       
    34 	dpatch cat-all >patch-stamp
       
    35 	touch patch-stamp
       
    36 
       
    37 unpatch:
       
    38 	dpatch deapply-all
       
    39 	rm -rf patch-stamp debian/patched
       
    40 
       
    41 build: build-stamp
    20 build: build-stamp
    42 
    21 
    43 build-stamp: configure-stamp patch
    22 build-stamp:
    44 	dh_testdir
    23 	dh_testdir
    45 
       
    46 	# Add here commands to compile the package.
    24 	# Add here commands to compile the package.
    47 	$(MAKE)
    25 	$(MAKE)
    48 	#docbook-to-man debian/matiec.sgml > matiec.1
       
    49 
       
    50 	touch $@
    26 	touch $@
    51 
    27 
    52 clean: unpatch
    28 clean:
    53 	dh_testdir
    29 	dh_testdir
    54 	dh_testroot
    30 	dh_testroot
    55 	rm -f build-stamp configure-stamp
    31 	rm -f build-stamp
    56 
    32 
    57 	# Add here commands to clean up after the build process.
    33 	# Add here commands to clean up after the build process.
    58 	-$(MAKE) clean
    34 	-$(MAKE) clean
    59 
    35 
    60 	dh_clean 
    36 	dh_clean 
    64 	dh_testroot
    40 	dh_testroot
    65 	dh_clean -k 
    41 	dh_clean -k 
    66 	dh_installdirs
    42 	dh_installdirs
    67 
    43 
    68 	# Add here commands to install the package into debian/matiec.
    44 	# Add here commands to install the package into debian/matiec.
    69 	$(MAKE) INSTALL_PREDIR=$(CURDIR)/debian/matiec/usr INSTALL_BINDIR=/bin IECLIBDIR=/lib install	
    45 	#$(MAKE) INSTALL_PREDIR=$(CURDIR)/debian/matiec/usr INSTALL_BINDIR=/bin IECLIBDIR=/lib install	
    70 	
    46 	
       
    47 	# Add here commands to install the package into debian/beremiz.
       
    48 	mkdir -p $(CURDIR)/debian/matiec/usr/share/matiec
       
    49 	
       
    50 	cp -a lib $(CURDIR)/debian/matiec/usr/share/matiec
       
    51 	cp iec2c $(CURDIR)/debian/matiec/usr/share/matiec
       
    52 		
    71 
    53 
    72 # Build architecture-independent files here.
    54 # Build architecture-independent files here.
    73 binary-indep: build install
    55 binary-indep: build install
    74 # We have nothing to do by default.
    56 # We have nothing to do by default.
    75 
    57 
   103 	dh_gencontrol
    85 	dh_gencontrol
   104 	dh_md5sums
    86 	dh_md5sums
   105 	dh_builddeb
    87 	dh_builddeb
   106 
    88 
   107 binary: binary-indep binary-arch
    89 binary: binary-indep binary-arch
   108 .PHONY: build clean binary-indep binary-arch binary install configure patch unpatch
    90 .PHONY: build clean binary-indep binary-arch binary install