debian/rules
changeset 106 0fff950e578e
child 171 59f5197b088a
equal deleted inserted replaced
105:7d138444b832 106:0fff950e578e
       
     1 #!/usr/bin/make -f
       
     2 # -*- makefile -*-
       
     3 # Sample debian/rules that uses debhelper.
       
     4 # This file was originally written by Joey Hess and Craig Small.
       
     5 # As a special exception, when this file is copied by dh-make into a
       
     6 # dh-make output file, you may use that output file without restriction.
       
     7 # This special exception was added by Craig Small in version 0.37 of dh-make.
       
     8 
       
     9 # Uncomment this to turn on verbose mode.
       
    10 export DH_VERBOSE=1
       
    11 
       
    12 CFLAGS = -Wall -g
       
    13 
       
    14 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
       
    15 	CFLAGS += -O0
       
    16 else
       
    17 	CFLAGS += -O2
       
    18 endif
       
    19 
       
    20 configure: configure-stamp
       
    21 configure-stamp:
       
    22 	dh_testdir
       
    23 	# Add here commands to configure the package.
       
    24 
       
    25 	touch configure-stamp
       
    26 
       
    27 ##############
       
    28 # And now the simple things for dpatch. Here we only apply/unapply the patches.
       
    29 # You can do more things with dpatch, like having patches only applied on
       
    30 # a special architecture - see the non-dh version of the sample for this!
       
    31 patch: patch-stamp
       
    32 patch-stamp:
       
    33 	dpatch apply-all
       
    34 	dpatch cat-all >patch-stamp
       
    35 	touch patch-stamp
       
    36 
       
    37 unpatch:
       
    38 	dpatch deapply-all
       
    39 	rm -rf patch-stamp debian/patched
       
    40 
       
    41 build: build-stamp
       
    42 
       
    43 build-stamp: configure-stamp patch
       
    44 	dh_testdir
       
    45 
       
    46 	# Add here commands to compile the package.
       
    47 	$(MAKE)
       
    48 	#docbook-to-man debian/matiec.sgml > matiec.1
       
    49 
       
    50 	touch $@
       
    51 
       
    52 clean: unpatch
       
    53 	dh_testdir
       
    54 	dh_testroot
       
    55 	rm -f build-stamp configure-stamp
       
    56 
       
    57 	# Add here commands to clean up after the build process.
       
    58 	-$(MAKE) clean
       
    59 
       
    60 	dh_clean 
       
    61 
       
    62 install: build
       
    63 	dh_testdir
       
    64 	dh_testroot
       
    65 	dh_clean -k 
       
    66 	dh_installdirs
       
    67 
       
    68 	# Add here commands to install the package into debian/matiec.
       
    69 	$(MAKE) INSTALL_PREDIR=$(CURDIR)/debian/matiec/usr INSTALL_BINDIR=/bin IECLIBDIR=/lib install	
       
    70 	
       
    71 
       
    72 # Build architecture-independent files here.
       
    73 binary-indep: build install
       
    74 # We have nothing to do by default.
       
    75 
       
    76 # Build architecture-dependent files here.
       
    77 binary-arch: build install
       
    78 	dh_testdir
       
    79 	dh_testroot
       
    80 	dh_installchangelogs 
       
    81 	dh_installdocs
       
    82 	dh_installexamples
       
    83 #	dh_install
       
    84 #	dh_installmenu
       
    85 #	dh_installdebconf	
       
    86 #	dh_installlogrotate
       
    87 #	dh_installemacsen
       
    88 #	dh_installpam
       
    89 #	dh_installmime
       
    90 #	dh_python
       
    91 #	dh_installinit
       
    92 #	dh_installcron
       
    93 #	dh_installinfo
       
    94 	dh_installman
       
    95 	dh_link
       
    96 	dh_strip
       
    97 	dh_compress
       
    98 	dh_fixperms
       
    99 #	dh_perl
       
   100 #	dh_makeshlibs
       
   101 	dh_installdeb
       
   102 	dh_shlibdeps
       
   103 	dh_gencontrol
       
   104 	dh_md5sums
       
   105 	dh_builddeb
       
   106 
       
   107 binary: binary-indep binary-arch
       
   108 .PHONY: build clean binary-indep binary-arch binary install configure patch unpatch