configure.ac
changeset 1253 8a081444a89a
parent 1242 632a6b91f8e4
child 1286 88e573e033f1
--- a/configure.ac	Thu Oct 09 09:48:59 2008 +0000
+++ b/configure.ac	Thu Oct 09 13:23:07 2008 +0000
@@ -370,6 +370,28 @@
 fi
 
 #------------------------------------------------------------------------------
+# Command-line tool
+#-----------------------------------------------------------------------------
+
+AC_ARG_ENABLE([tool],
+    AS_HELP_STRING([--enable-tool],
+                   [Build command-line tool (default: yes)]),
+    [
+        case "${enableval}" in
+            yes) tool=1
+                ;;
+            no) tool=0
+                ;;
+            *) AC_MSG_ERROR([Invalid value for --enable-tool])
+                ;;
+        esac
+    ],
+    [tool=1]
+)
+
+AM_CONDITIONAL(BUILD_TOOL, test "x$tool" = "x1")
+
+#------------------------------------------------------------------------------
 # Userspace library generation
 #------------------------------------------------------------------------------