configure.ac
changeset 1242 632a6b91f8e4
parent 1234 ed5a56863603
child 1253 8a081444a89a
--- a/configure.ac	Wed Oct 01 14:37:34 2008 +0000
+++ b/configure.ac	Wed Oct 01 14:42:28 2008 +0000
@@ -15,6 +15,7 @@
 #------------------------------------------------------------------------------
 
 AC_PROG_CXX
+AC_PROG_LIBTOOL
 
 #------------------------------------------------------------------------------
 # Linux sources
@@ -369,6 +370,28 @@
 fi
 
 #------------------------------------------------------------------------------
+# Userspace library generation
+#------------------------------------------------------------------------------
+
+AC_ARG_ENABLE([userlib],
+    AS_HELP_STRING([--enable-userlib],
+                   [Generation of the userspace library (default: yes)]),
+    [
+        case "${enableval}" in
+            yes) userlib=1
+                ;;
+            no) userlib=0
+                ;;
+            *) AC_MSG_ERROR([Invalid value for --enable-userlib])
+                ;;
+        esac
+    ],
+    [userlib=1]
+)
+
+AM_CONDITIONAL(ENABLE_USERLIB, test "x$userlib" = "x1")
+
+#------------------------------------------------------------------------------
 
 AC_CONFIG_FILES([
         Doxyfile
@@ -383,7 +406,9 @@
         examples/mini/Makefile
         examples/rtai/Kbuild
         examples/rtai/Makefile
+        examples/user/Makefile
         include/Makefile
+        lib/Makefile
         master/Kbuild
         master/Makefile
         script/Makefile