configure.ac
branchstable-1.5
changeset 2556 674fcdccc0f3
parent 2540 fca12d7035d1
parent 2553 b0c2762a1a83
child 2557 ded6d50de4a7
--- a/configure.ac	Mon Mar 10 13:43:48 2014 +0100
+++ b/configure.ac	Fri Apr 25 16:42:36 2014 +0200
@@ -247,6 +247,44 @@
 AC_SUBST(KERNEL_8139TOO,[$kernel8139too])
 
 #------------------------------------------------------------------------------
+# CCAT driver
+#------------------------------------------------------------------------------
+
+AC_ARG_ENABLE([ccat],
+    AS_HELP_STRING([--enable-ccat],
+                   [Enable CCAT driver]),
+    [
+        case "${enableval}" in
+            yes) enableccat=1
+                ;;
+            no) enableccat=0
+                ;;
+            *) AC_MSG_ERROR([Invalid value for --enable-ccat])
+                ;;
+        esac
+    ],
+    [enableccat=0] # disabled by default
+)
+
+AM_CONDITIONAL(ENABLE_CCAT, test "x$enableccat" = "x1")
+AC_SUBST(ENABLE_CCAT,[$enableccat])
+
+AC_ARG_WITH([ccat-kernel],
+    AC_HELP_STRING(
+        [--with-ccat-kernel=<X.Y.Z>],
+        [ccat kernel (only if differing)]
+    ),
+    [
+        kernelccat=[$withval]
+    ],
+    [
+        kernelccat=$linuxversion
+    ]
+)
+
+AC_SUBST(KERNEL_CCAT,[$kernelccat])
+
+#------------------------------------------------------------------------------
 # e100 driver
 #------------------------------------------------------------------------------
 
@@ -1003,6 +1041,8 @@
         Makefile
         devices/Kbuild
         devices/Makefile
+        devices/ccat/Kbuild
+        devices/ccat/Makefile
         devices/e1000/Kbuild
         devices/e1000/Makefile
         devices/e1000e/Kbuild