debian/rules
author greg
Tue, 29 Jan 2008 11:17:26 +0100
changeset 92 b4e25e5030d4
parent 91 8d6dd867cf27
child 318 b24790c748ae
permissions -rwxr-xr-x
remove deb_dist in debian/rules
#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1




CFLAGS = -Wall -g

ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
	CFLAGS += -O0
else
	CFLAGS += -O2
endif

configure: configure-stamp
configure-stamp:
	dh_testdir
	# Add here commands to configure the package.

	touch configure-stamp


build: build-stamp

build-stamp: configure-stamp 
	dh_testdir

	# Add here commands to compile the package.
	#$(MAKE)
	#docbook-to-man debian/beremiz.sgml > beremiz.1

	touch $@

clean:
	dh_testdir
	dh_testroot
	rm -f build-stamp configure-stamp

	# Add here commands to clean up after the build process.
	#-$(MAKE) clean

	dh_clean 

install: build
	dh_testdir
	dh_testroot
	dh_clean -k 
	dh_installdirs

	# Add here commands to install the package into debian/beremiz.
	#$(MAKE) DESTDIR=$(CURDIR)/debian/beremiz install
	mkdir -p $(CURDIR)/debian/beremiz/usr/share/beremiz
	cp -a images $(CURDIR)/debian/beremiz/usr/share/beremiz
	cp -a plugins $(CURDIR)/debian/beremiz/usr/share/beremiz
	cp -a runtime $(CURDIR)/debian/beremiz/usr/share/beremiz
	cp -a test $(CURDIR)/debian/beremiz/usr/share/beremiz
	cp *.py $(CURDIR)/debian/beremiz/usr/share/beremiz

	chmod -R a+r $(CURDIR)/debian/beremiz

# Build architecture-independent files here.
binary-indep: build install
# We have nothing to do by default.

# Build architecture-dependent files here.
binary-arch: build install
	dh_testdir
	dh_testroot
	dh_installchangelogs 
	dh_installdocs
	dh_installexamples
#	dh_install
#	dh_installmenu
#	dh_installdebconf	
#	dh_installlogrotate
#	dh_installemacsen
#	dh_installpam
#	dh_installmime
#	dh_python
#	dh_installinit
#	dh_installcron
#	dh_installinfo
	dh_installman
	dh_link
	dh_strip
	dh_compress
	dh_fixperms
#	dh_perl
#	dh_makeshlibs
	dh_installdeb
	dh_shlibdeps
	dh_gencontrol
	dh_md5sums
	dh_builddeb

binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure