debian/rules
author laurent
Thu, 08 Oct 2009 11:26:40 +0200
changeset 411 8261c8f1e365
parent 318 b24790c748ae
child 432 ef7fc6fd1f6f
permissions -rwxr-xr-x
Bug on Debug trying to start (and stop) before PLC started fixed.
Adding support for detecting platform default settings for target type and canfestival node.
Clear tests folder, leaving only multi-platform tests.
#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1




CFLAGS = -Wall -g

ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
	CFLAGS += -O0
else
	CFLAGS += -O2
endif

configure: configure-stamp
configure-stamp:
	dh_testdir
	# Add here commands to configure the package.

	touch configure-stamp


build: build-stamp

build-stamp: configure-stamp 
	dh_testdir

	# Add here commands to compile the package.
	#$(MAKE)
	#docbook-to-man debian/beremiz.sgml > beremiz.1

	touch $@

clean:
	dh_testdir
	dh_testroot
	rm -f build-stamp configure-stamp

	# Add here commands to clean up after the build process.
	#-$(MAKE) clean

	dh_clean 

install: build
	dh_testdir
	dh_testroot
	dh_clean -k 
	dh_installdirs

	# Add here commands to install the package into debian/beremiz.
	mkdir -p $(CURDIR)/debian/beremiz/usr/share/beremiz
	mkdir -p $(CURDIR)/debian/beremiz/usr/share/applications
	
	cp -a images $(CURDIR)/debian/beremiz/usr/share/beremiz
	cp -a plugins $(CURDIR)/debian/beremiz/usr/share/beremiz
	cp -a runtime $(CURDIR)/debian/beremiz/usr/share/beremiz
	cp -a tests $(CURDIR)/debian/beremiz/usr/share/beremiz
	cp -a connectors $(CURDIR)/debian/beremiz/usr/share/beremiz
	cp -a targets $(CURDIR)/debian/beremiz/usr/share/beremiz
	cp *.xml $(CURDIR)/debian/beremiz/usr/share/beremiz
	cp *.py $(CURDIR)/debian/beremiz/usr/share/beremiz

	cp debian/beremiz.desktop $(CURDIR)/debian/beremiz/usr/share/applications/beremiz.desktop

	rm -rf `find .|grep CVS`
	rm -rf `find .|grep .cvsignore`
	chmod -R a+r $(CURDIR)/debian/beremiz

# Build architecture-independent files here.
binary-indep: build install
# We have nothing to do by default.

# Build architecture-dependent files here.
binary-arch: build install
	dh_testdir
	dh_testroot
	dh_installchangelogs 
	dh_installdocs
	dh_installexamples
#	dh_install
#	dh_installmenu
#	dh_installdebconf	
#	dh_installlogrotate
#	dh_installemacsen
#	dh_installpam
#	dh_installmime
#	dh_python
#	dh_installinit
#	dh_installcron
#	dh_installinfo
	dh_installman
	dh_link
	dh_strip
	dh_compress
	dh_fixperms
#	dh_perl
#	dh_makeshlibs
	dh_installdeb
#	dh_shlibdeps
	dh_gencontrol
	dh_md5sums
	dh_builddeb

binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure