debian/rules
changeset 432 ef7fc6fd1f6f
parent 318 b24790c748ae
equal deleted inserted replaced
429:1a5471e81a93 432:ef7fc6fd1f6f
     1 #!/usr/bin/make -f
     1 #!/usr/bin/make -f
     2 # -*- makefile -*-
     2 # -*- makefile -*-
     3 # Sample debian/rules that uses debhelper.
       
     4 # This file was originally written by Joey Hess and Craig Small.
       
     5 # As a special exception, when this file is copied by dh-make into a
       
     6 # dh-make output file, you may use that output file without restriction.
       
     7 # This special exception was added by Craig Small in version 0.37 of dh-make.
       
     8 
     3 
     9 # Uncomment this to turn on verbose mode.
     4 # Uncomment this to turn on verbose mode.
    10 #export DH_VERBOSE=1
     5 #export DH_VERBOSE=1
    11 
       
    12 
       
    13 
       
    14 
     6 
    15 CFLAGS = -Wall -g
     7 CFLAGS = -Wall -g
    16 
     8 
    17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
     9 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
    18 	CFLAGS += -O0
    10 	CFLAGS += -O0
    21 endif
    13 endif
    22 
    14 
    23 configure: configure-stamp
    15 configure: configure-stamp
    24 configure-stamp:
    16 configure-stamp:
    25 	dh_testdir
    17 	dh_testdir
    26 	# Add here commands to configure the package.
       
    27 
       
    28 	touch configure-stamp
    18 	touch configure-stamp
    29 
    19 
    30 
    20 
    31 build: build-stamp
    21 build: build-stamp
    32 
    22 
    33 build-stamp: configure-stamp 
    23 build-stamp: configure-stamp 
    34 	dh_testdir
    24 	dh_testdir
    35 
       
    36 	# Add here commands to compile the package.
       
    37 	#$(MAKE)
       
    38 	#docbook-to-man debian/beremiz.sgml > beremiz.1
       
    39 
       
    40 	touch $@
    25 	touch $@
    41 
    26 
    42 clean:
    27 clean:
    43 	dh_testdir
    28 	dh_testdir
    44 	dh_testroot
    29 	dh_testroot
    45 	rm -f build-stamp configure-stamp
    30 	rm -f build-stamp configure-stamp
    46 
       
    47 	# Add here commands to clean up after the build process.
       
    48 	#-$(MAKE) clean
       
    49 
       
    50 	dh_clean 
    31 	dh_clean 
    51 
    32 
    52 install: build
    33 install: build
    53 	dh_testdir
    34 	dh_testdir
    54 	dh_testroot
    35 	dh_testroot
    55 	dh_clean -k 
    36 	dh_clean -k 
    56 	dh_installdirs
    37 	dh_installdirs
    57 
    38 
    58 	# Add here commands to install the package into debian/beremiz.
    39 	# Copy source files
    59 	mkdir -p $(CURDIR)/debian/beremiz/usr/share/beremiz
    40 	mkdir -p $(CURDIR)/debian/beremiz/usr/share/beremiz
    60 	mkdir -p $(CURDIR)/debian/beremiz/usr/share/applications
       
    61 	
       
    62 	cp -a images $(CURDIR)/debian/beremiz/usr/share/beremiz
    41 	cp -a images $(CURDIR)/debian/beremiz/usr/share/beremiz
    63 	cp -a plugins $(CURDIR)/debian/beremiz/usr/share/beremiz
    42 	cp -a plugins $(CURDIR)/debian/beremiz/usr/share/beremiz
    64 	cp -a runtime $(CURDIR)/debian/beremiz/usr/share/beremiz
    43 	cp -a runtime $(CURDIR)/debian/beremiz/usr/share/beremiz
    65 	cp -a tests $(CURDIR)/debian/beremiz/usr/share/beremiz
    44 	cp -a tests $(CURDIR)/debian/beremiz/usr/share/beremiz
    66 	cp -a connectors $(CURDIR)/debian/beremiz/usr/share/beremiz
    45 	cp -a connectors $(CURDIR)/debian/beremiz/usr/share/beremiz
    67 	cp -a targets $(CURDIR)/debian/beremiz/usr/share/beremiz
    46 	cp -a targets $(CURDIR)/debian/beremiz/usr/share/beremiz
    68 	cp *.xml $(CURDIR)/debian/beremiz/usr/share/beremiz
    47 	cp -a doc $(CURDIR)/debian/beremiz/usr/share/beremiz
       
    48 	cp -a locale $(CURDIR)/debian/beremiz/usr/share/beremiz
       
    49 	cp *.js $(CURDIR)/debian/beremiz/usr/share/beremiz
    69 	cp *.py $(CURDIR)/debian/beremiz/usr/share/beremiz
    50 	cp *.py $(CURDIR)/debian/beremiz/usr/share/beremiz
    70 
    51 
    71 	cp debian/beremiz.desktop $(CURDIR)/debian/beremiz/usr/share/applications/beremiz.desktop
    52 	# Copy desktop directory file
    72 
    53 	mkdir -p $(CURDIR)/debian/beremiz/usr/share/desktop-directories
       
    54 	cp debian/Beremiz.directory $(CURDIR)/debian/beremiz/usr/share/desktop-directories
       
    55 	cp debian/Beremiz_demos.directory $(CURDIR)/debian/beremiz/usr/share/desktop-directories
       
    56 	cp debian/Beremiz_docs.directory $(CURDIR)/debian/beremiz/usr/share/desktop-directories
       
    57 	
       
    58 	# Copy desktop menu file
       
    59 	mkdir -p $(CURDIR)/debian/beremiz/etc/xdg/menus/applications-merged
       
    60 	cp debian/beremiz.menu $(CURDIR)/debian/beremiz/etc/xdg/menus/applications-merged
       
    61 	
       
    62 	# Copy desktop entry files
       
    63 	mkdir -p $(CURDIR)/debian/beremiz/usr/share/applications
       
    64 	cp debian/beremiz.desktop $(CURDIR)/debian/beremiz/usr/share/applications/
       
    65 	cp debian/beremiz_svgui.desktop $(CURDIR)/debian/beremiz/usr/share/applications/
       
    66 	cp debian/beremiz_wxglade.desktop $(CURDIR)/debian/beremiz/usr/share/applications/
       
    67 	cp debian/beremiz_doc.desktop $(CURDIR)/debian/beremiz/usr/share/applications/
       
    68 	
    73 	rm -rf `find .|grep CVS`
    69 	rm -rf `find .|grep CVS`
    74 	rm -rf `find .|grep .cvsignore`
    70 	rm -rf `find .|grep .cvsignore`
    75 	chmod -R a+r $(CURDIR)/debian/beremiz
    71 	chmod -R a+r $(CURDIR)/debian/beremiz
    76 
    72 
    77 # Build architecture-independent files here.
    73 # Build architecture-independent files here.
    78 binary-indep: build install
    74 binary-indep: build install
    79 # We have nothing to do by default.
       
    80 
    75 
    81 # Build architecture-dependent files here.
    76 # Build architecture-dependent files here.
    82 binary-arch: build install
    77 binary-arch: build install
    83 	dh_testdir
    78 	dh_testdir
    84 	dh_testroot
    79 	dh_testroot
    85 	dh_installchangelogs 
    80 #	dh_installchangelogs 
    86 	dh_installdocs
    81 #	dh_installdocs
    87 	dh_installexamples
    82 	dh_installexamples
    88 #	dh_install
    83 #	dh_install
    89 #	dh_installmenu
    84 #	dh_installmenu
    90 #	dh_installdebconf	
    85 #	dh_installdebconf	
    91 #	dh_installlogrotate
    86 #	dh_installlogrotate