|
1 #!/usr/bin/make -f |
|
2 # -*- makefile -*- |
|
3 # Sample debian/rules that uses debhelper. |
|
4 # This file was originally written by Joey Hess and Craig Small. |
|
5 # As a special exception, when this file is copied by dh-make into a |
|
6 # dh-make output file, you may use that output file without restriction. |
|
7 # This special exception was added by Craig Small in version 0.37 of dh-make. |
|
8 |
|
9 # Uncomment this to turn on verbose mode. |
|
10 #export DH_VERBOSE=1 |
|
11 |
|
12 |
|
13 |
|
14 |
|
15 CFLAGS = -Wall -g |
|
16 |
|
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
|
18 CFLAGS += -O0 |
|
19 else |
|
20 CFLAGS += -O2 |
|
21 endif |
|
22 |
|
23 configure: configure-stamp |
|
24 configure-stamp: |
|
25 dh_testdir |
|
26 # Add here commands to configure the package. |
|
27 |
|
28 touch configure-stamp |
|
29 |
|
30 |
|
31 build: build-stamp |
|
32 |
|
33 build-stamp: configure-stamp |
|
34 dh_testdir |
|
35 |
|
36 # Add here commands to compile the package. |
|
37 #$(MAKE) |
|
38 #docbook-to-man debian/beremiz.sgml > beremiz.1 |
|
39 |
|
40 touch $@ |
|
41 |
|
42 clean: |
|
43 dh_testdir |
|
44 dh_testroot |
|
45 rm -f build-stamp configure-stamp |
|
46 |
|
47 # Add here commands to clean up after the build process. |
|
48 #-$(MAKE) clean |
|
49 |
|
50 dh_clean |
|
51 |
|
52 install: build |
|
53 dh_testdir |
|
54 dh_testroot |
|
55 dh_clean -k |
|
56 dh_installdirs |
|
57 |
|
58 # Add here commands to install the package into debian/beremiz. |
|
59 #$(MAKE) DESTDIR=$(CURDIR)/debian/beremiz install |
|
60 mkdir -p $(CURDIR)/debian/beremiz/usr/share/beremiz |
|
61 cp -a images $(CURDIR)/debian/beremiz/usr/share/beremiz |
|
62 cp -a plugins $(CURDIR)/debian/beremiz/usr/share/beremiz |
|
63 cp -a runtime $(CURDIR)/debian/beremiz/usr/share/beremiz |
|
64 cp -a test $(CURDIR)/debian/beremiz/usr/share/beremiz |
|
65 cp *.py $(CURDIR)/debian/beremiz/usr/share/beremiz |
|
66 |
|
67 chmod -R a+r $(CURDIR)/debian/beremiz |
|
68 |
|
69 # Build architecture-independent files here. |
|
70 binary-indep: build install |
|
71 # We have nothing to do by default. |
|
72 |
|
73 # Build architecture-dependent files here. |
|
74 binary-arch: build install |
|
75 dh_testdir |
|
76 dh_testroot |
|
77 dh_installchangelogs |
|
78 dh_installdocs |
|
79 dh_installexamples |
|
80 # dh_install |
|
81 # dh_installmenu |
|
82 # dh_installdebconf |
|
83 # dh_installlogrotate |
|
84 # dh_installemacsen |
|
85 # dh_installpam |
|
86 # dh_installmime |
|
87 # dh_python |
|
88 # dh_installinit |
|
89 # dh_installcron |
|
90 # dh_installinfo |
|
91 dh_installman |
|
92 dh_link |
|
93 dh_strip |
|
94 dh_compress |
|
95 dh_fixperms |
|
96 # dh_perl |
|
97 # dh_makeshlibs |
|
98 dh_installdeb |
|
99 dh_shlibdeps |
|
100 dh_gencontrol |
|
101 dh_md5sums |
|
102 dh_builddeb --destdir=../../../deb_files |
|
103 |
|
104 binary: binary-indep binary-arch |
|
105 .PHONY: build clean binary-indep binary-arch binary install configure |