setup.py
changeset 60 b19d0a86651b
parent 56 d48cf08cf448
child 62 00a196f8d14a
--- a/setup.py	Wed Mar 18 19:32:02 2020 +0100
+++ b/setup.py	Thu Mar 19 14:53:28 2020 +0100
@@ -1,36 +1,49 @@
 # -*- coding: utf-8 -*-
 
-import sys
+import sys, os
 from setuptools import setup
 
-sys.path.insert(0, '.')
-from yml2 import yml2c
-caption = yml2c.__doc__.split('\n')[0]
-short_desc, version = map(lambda s: s.strip(), caption.split('version', 1))
+DESC = "YML 2 compiler"
+SDISTVER = '2.6.2.3'
 
-with open('README.md', 'r') as fh:
+with open('README.rst', 'r', encoding='utf-8') as fh:
     long_desc = fh.read().strip()
+    long_description_content_type = 'text/markdown'
 
 setup(
-        name='YML2',
-        version=version,
-        description=short_desc,
-        long_description=long_desc,
-        author="Volker Birk",
-        author_email="vb@pep.foundation",
-        url="https://pep.foundation/dev/repos/yml2",
-        zip_safe=False,
-        packages=["yml2"],
-        install_requires=['lxml'],
-        package_data = {
-            '': ['gpl-2.0.txt', '*.css', '*.yhtml2'],
-            'yml2': ['*.yml2', '*.ysl2'],
-        },
-        entry_points = {
-            'console_scripts': [
-                'yml2c=yml2.yml2c:main',
-                'yml2proc=yml2.yml2proc:main'
-            ],
-        }
-    )
+    name='YML2',
+    version=SDISTVER,
+    description=DESC,
+    long_description=long_desc,
+    long_description_content_type=long_description_content_type,
+    author="Volker Birk",
+    author_email="vb@pep.foundation",
+    license="GPL-2.0",
+    url="https://pep.foundation/dev/repos/yml2",
+    download_url="https://software.pep.foundation/r/pypi/yml2/YML2-%s.tar.gz" % SDISTVER,
+    zip_safe=False,
+    packages=["yml2"],
+    install_requires=['lxml'],
+    package_data = {
+        '': ['COPYING.txt', '*.css', '*.yhtml2'],
+        'yml2': ['*.yml2', '*.ysl2'],
+    },
+    entry_points = {
+        'console_scripts': [
+            'yml2c=yml2.yml2c:main',
+            'yml2proc=yml2.yml2proc:main'
+        ],
+    },
+    classifiers=[
+      'Development Status :: 5 - Production/Stable',
+      'Intended Audience :: Developers',
+      'Environment :: Console',
+      'Topic :: Software Development :: Build Tools',
+      'License :: OSI Approved :: GNU General Public License v2 (GPLv2)',
+      'Programming Language :: Python :: 3',
+      'Programming Language :: Python :: 3.4',
+      'Programming Language :: Python :: 3.5',
+      'Programming Language :: Python :: 3.6',
+    ],
+)