setup.py
changeset 62 00a196f8d14a
parent 60 b19d0a86651b
child 65 d659b8c2ed22
--- a/setup.py	Thu Mar 19 14:54:23 2020 +0100
+++ b/setup.py	Thu Mar 19 16:45:02 2020 +0100
@@ -1,33 +1,13 @@
 # -*- coding: utf-8 -*-
 
-import sys, os
-from setuptools import setup
+from setuptools import setup, find_packages
 
-DESC = "YML 2 compiler"
-SDISTVER = '2.6.2.3'
-
-with open('README.rst', 'r', encoding='utf-8') as fh:
-    long_desc = fh.read().strip()
-    long_description_content_type = 'text/markdown'
+with open('README.rst', 'r', encoding='utf-8') as f:
+    long_description = f.read()
 
 setup(
-    name='YML2',
-    version=SDISTVER,
-    description=DESC,
-    long_description=long_desc,
-    long_description_content_type=long_description_content_type,
-    author="Volker Birk",
-    author_email="vb@pep.foundation",
-    license="GPL-2.0",
-    url="https://pep.foundation/dev/repos/yml2",
-    download_url="https://software.pep.foundation/r/pypi/yml2/YML2-%s.tar.gz" % SDISTVER,
-    zip_safe=False,
-    packages=["yml2"],
-    install_requires=['lxml'],
-    package_data = {
-        '': ['COPYING.txt', '*.css', '*.yhtml2'],
-        'yml2': ['*.yml2', '*.ysl2'],
-    },
+    setup_requires = ["setuptools >= 30.3.0"],  # release 2016-12-06
+    long_description=long_description,
     entry_points = {
         'console_scripts': [
             'yml2c=yml2.yml2c:main',