debian/rules
changeset 314 c9291298c5b8
parent 161 6af49f77fa2b
child 453 d01e025b868d
--- a/debian/rules	Wed Feb 25 16:39:39 2009 +0100
+++ b/debian/rules	Mon Mar 02 09:29:22 2009 +0100
@@ -51,15 +51,19 @@
 	
 	### Installing the data files
 	# should be copied to /usr/local/objdictedit
-	cp -r examples Images graphics plcopen snapshots minixsv \
-		$(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor
+	cp -r examples $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor
+	cp -r Images $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor
+	cp -r graphics $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor
+	cp -r plcopen $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor
+	cp -r examples $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor
 	cp *.py $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor
+	rm -rf `find .|grep CVS`
+	rm -rf `find .|grep .cvsignore`
 	chmod -R a+r $(CURDIR)/debian/plcopeneditor 
 
 	### Installing menufile
 	# Now copy the file with the menu entry into /usr/share/applications.
 	cp debian/plcopeneditor.desktop $(CURDIR)/debian/plcopeneditor/usr/share/applications/
-	cp debian/plcopeneditor.png $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor/plcopeneditor.png
 	
 # Build architecture-independent files here.
 binary-indep: build install