debian/rules
changeset 314 c9291298c5b8
parent 161 6af49f77fa2b
child 453 d01e025b868d
equal deleted inserted replaced
313:9266d1e6e3d4 314:c9291298c5b8
    49 	# Add here commands to install the package into debian/plcopeneditor.
    49 	# Add here commands to install the package into debian/plcopeneditor.
    50 	mkdir -p $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor	
    50 	mkdir -p $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor	
    51 	
    51 	
    52 	### Installing the data files
    52 	### Installing the data files
    53 	# should be copied to /usr/local/objdictedit
    53 	# should be copied to /usr/local/objdictedit
    54 	cp -r examples Images graphics plcopen snapshots minixsv \
    54 	cp -r examples $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor
    55 		$(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor
    55 	cp -r Images $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor
       
    56 	cp -r graphics $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor
       
    57 	cp -r plcopen $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor
       
    58 	cp -r examples $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor
    56 	cp *.py $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor
    59 	cp *.py $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor
       
    60 	rm -rf `find .|grep CVS`
       
    61 	rm -rf `find .|grep .cvsignore`
    57 	chmod -R a+r $(CURDIR)/debian/plcopeneditor 
    62 	chmod -R a+r $(CURDIR)/debian/plcopeneditor 
    58 
    63 
    59 	### Installing menufile
    64 	### Installing menufile
    60 	# Now copy the file with the menu entry into /usr/share/applications.
    65 	# Now copy the file with the menu entry into /usr/share/applications.
    61 	cp debian/plcopeneditor.desktop $(CURDIR)/debian/plcopeneditor/usr/share/applications/
    66 	cp debian/plcopeneditor.desktop $(CURDIR)/debian/plcopeneditor/usr/share/applications/
    62 	cp debian/plcopeneditor.png $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor/plcopeneditor.png
       
    63 	
    67 	
    64 # Build architecture-independent files here.
    68 # Build architecture-independent files here.
    65 binary-indep: build install
    69 binary-indep: build install
    66 # We have nothing to do by default.
    70 # We have nothing to do by default.
    67 
    71