debian/rules
changeset 139 c2d093402005
child 161 6af49f77fa2b
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/debian/rules	Mon Dec 31 13:36:11 2007 +0100
@@ -0,0 +1,100 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+	CFLAGS += -O0
+else
+	CFLAGS += -O2
+endif
+
+configure: configure-stamp
+configure-stamp:
+	dh_testdir
+	# Add here commands to configure the package.
+
+	touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp 
+	dh_testdir
+	touch $@
+
+clean:
+	dh_testdir
+	dh_testroot
+	rm -f build-stamp configure-stamp
+	dh_clean 
+
+install: build
+	dh_testdir
+	dh_testroot
+	dh_clean -k 
+	dh_installdirs
+
+	# Add here commands to install the package into debian/plcopeneditor.
+	mkdir -p $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor	
+	
+	### Installing the data files
+	# should be copied to /usr/local/objdictedit
+	cp -r examples Images graphics plcopen xmlclass snapshots minixsv \
+		$(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor
+	cp *.py $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor
+	chmod -R a+r $(CURDIR)/debian/plcopeneditor 
+
+	### Installing menufile
+	# Now copy the file with the menu entry into /usr/share/applications.
+	cp debian/plcopeneditor.desktop $(CURDIR)/debian/plcopeneditor/usr/share/applications/
+	cp debian/plcopeneditor.png $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor/plcopeneditor.png
+	
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+	dh_testdir
+	dh_testroot
+	dh_installchangelogs 
+	dh_installdocs
+	dh_installexamples
+#	dh_install
+#	dh_installmenu
+#	dh_installdebconf	
+#	dh_installlogrotate
+#	dh_installemacsen
+#	dh_installpam
+#	dh_installmime
+#	dh_python
+#	dh_installinit
+#	dh_installcroncp sss
+#	dh_installinfo
+	dh_installman
+	dh_link
+	dh_strip
+	dh_compress
+	dh_fixperms
+#	dh_perl
+#	dh_makeshlibs
+	dh_installdeb
+	dh_shlibdeps
+	dh_gencontrol
+	dh_md5sums
+	dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure