|
1 #!/usr/bin/make -f |
|
2 # -*- makefile -*- |
|
3 # Sample debian/rules that uses debhelper. |
|
4 # This file was originally written by Joey Hess and Craig Small. |
|
5 # As a special exception, when this file is copied by dh-make into a |
|
6 # dh-make output file, you may use that output file without restriction. |
|
7 # This special exception was added by Craig Small in version 0.37 of dh-make. |
|
8 |
|
9 # Uncomment this to turn on verbose mode. |
|
10 #export DH_VERBOSE=1 |
|
11 |
|
12 |
|
13 |
|
14 |
|
15 CFLAGS = -Wall -g |
|
16 |
|
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
|
18 CFLAGS += -O0 |
|
19 else |
|
20 CFLAGS += -O2 |
|
21 endif |
|
22 |
|
23 configure: configure-stamp |
|
24 configure-stamp: |
|
25 dh_testdir |
|
26 # Add here commands to configure the package. |
|
27 |
|
28 touch configure-stamp |
|
29 |
|
30 |
|
31 build: build-stamp |
|
32 |
|
33 build-stamp: configure-stamp |
|
34 dh_testdir |
|
35 touch $@ |
|
36 |
|
37 clean: |
|
38 dh_testdir |
|
39 dh_testroot |
|
40 rm -f build-stamp configure-stamp |
|
41 dh_clean |
|
42 |
|
43 install: build |
|
44 dh_testdir |
|
45 dh_testroot |
|
46 dh_clean -k |
|
47 dh_installdirs |
|
48 |
|
49 # Add here commands to install the package into debian/plcopeneditor. |
|
50 mkdir -p $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor |
|
51 |
|
52 ### Installing the data files |
|
53 # should be copied to /usr/local/objdictedit |
|
54 cp -r examples Images graphics plcopen xmlclass snapshots minixsv \ |
|
55 $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor |
|
56 cp *.py $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor |
|
57 chmod -R a+r $(CURDIR)/debian/plcopeneditor |
|
58 |
|
59 ### Installing menufile |
|
60 # Now copy the file with the menu entry into /usr/share/applications. |
|
61 cp debian/plcopeneditor.desktop $(CURDIR)/debian/plcopeneditor/usr/share/applications/ |
|
62 cp debian/plcopeneditor.png $(CURDIR)/debian/plcopeneditor/usr/share/plcopeneditor/plcopeneditor.png |
|
63 |
|
64 # Build architecture-independent files here. |
|
65 binary-indep: build install |
|
66 # We have nothing to do by default. |
|
67 |
|
68 # Build architecture-dependent files here. |
|
69 binary-arch: build install |
|
70 dh_testdir |
|
71 dh_testroot |
|
72 dh_installchangelogs |
|
73 dh_installdocs |
|
74 dh_installexamples |
|
75 # dh_install |
|
76 # dh_installmenu |
|
77 # dh_installdebconf |
|
78 # dh_installlogrotate |
|
79 # dh_installemacsen |
|
80 # dh_installpam |
|
81 # dh_installmime |
|
82 # dh_python |
|
83 # dh_installinit |
|
84 # dh_installcroncp sss |
|
85 # dh_installinfo |
|
86 dh_installman |
|
87 dh_link |
|
88 dh_strip |
|
89 dh_compress |
|
90 dh_fixperms |
|
91 # dh_perl |
|
92 # dh_makeshlibs |
|
93 dh_installdeb |
|
94 dh_shlibdeps |
|
95 dh_gencontrol |
|
96 dh_md5sums |
|
97 dh_builddeb |
|
98 |
|
99 binary: binary-indep binary-arch |
|
100 .PHONY: build clean binary-indep binary-arch binary install configure |