configure.ac
changeset 644 e7ac0fe9a287
parent 642 2ca07e3b08d6
child 1027 675ee2eeb3ff
--- a/configure.ac	Wed Aug 29 19:38:15 2012 +0100
+++ b/configure.ac	Wed Aug 29 21:52:33 2012 +0100
@@ -28,7 +28,8 @@
 AC_PROG_AWK
 
 # Check bison version, we need a version great or equal than 2.4 to build matiec.
-[[[ $(bison --version) =~ ([0-9][.][0-9]*) ]]] && version_bison="${BASH_REMATCH[[1]]}"
+version_bison="$(bison --version | sed q | cut -d' ' -f4)"
+version_bison=${version_bison:0:3}
 
 AS_IF([awk -v ver="$version_bison" 'BEGIN { if (ver < 2.4) exit 1; }'],
 	[have_bison_correct=yes], [have_bison_correct=no])