configure.ac
changeset 692 fe7cf37c33f1
parent 686 ca85fe008581
child 701 aac472ccd54c
--- a/configure.ac	Thu Aug 09 14:47:37 2007 +0000
+++ b/configure.ac	Thu Aug 09 15:01:14 2007 +0000
@@ -368,6 +368,30 @@
 AM_CONDITIONAL(ENABLE_DEBUG_IF, test "x$dbg" = "x1")
 
 #------------------------------------------------------------------------------
+# Debug ring
+#------------------------------------------------------------------------------
+
+AC_ARG_ENABLE([debug-ring],
+    AS_HELP_STRING([--enable-debug-ring],
+                   [Create a debug ring to record frames @<:@NO@:>@]),
+    [
+        case "${enableval}" in
+            yes) debugring=1
+                ;;
+            no) debugring=0
+                ;;
+            *) AC_MSG_ERROR([Invalid value for --enable-debug-ring])
+                ;;
+        esac
+    ],
+    [debugring=0]
+)
+
+if test "x${debugring}" = "x1"; then
+    AC_DEFINE([EC_DEBUG_RING], [1], [Debug ring enabled])
+fi
+
+#------------------------------------------------------------------------------
 # Dummy master module
 #------------------------------------------------------------------------------