configure.ac
changeset 392 eaee3c8d6ae0
parent 387 e6e708a5d502
child 393 9cfbb344adc0
--- a/configure.ac	Fri Oct 13 09:05:45 2006 +0000
+++ b/configure.ac	Fri Oct 13 09:38:23 2006 +0000
@@ -2,10 +2,13 @@
 # $Id$
 #------------------------------------------------------------------------------
 
+AC_PREREQ(2.59)
 AC_INIT([ethercat],[1.1],[fp@igh-essen.com])
 AC_CONFIG_AUX_DIR([autoconf])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign dist-bzip2])
 AC_PREFIX_DEFAULT([/opt/etherlab])
-AM_INIT_AUTOMAKE([-Wall -Werror foreign dist-bzip2])
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_SRCDIR([config.h.in])
 
 #------------------------------------------------------------------------------
 # Linux sources
@@ -49,11 +52,32 @@
 fi
 
 #------------------------------------------------------------------------------
+# Debug interface
+#------------------------------------------------------------------------------
+
+AC_ARG_ENABLE([debug-if],
+		AS_HELP_STRING([--enable-dbg-if],
+						[Create a debug interface for each master @<:@NO@:>@]),
+		[case "${enableval}" in
+			  yes) dbg=1
+				   AC_DEFINE([EC_DBG_IF], [1], [Debug interfaces enabled])
+				   ;;
+			  no)  dbg=0
+				   ;;
+			  *)   AC_MSG_ERROR([Invalid value for --enable-dbg-if])
+				   ;;
+		esac],
+		[dbg=0]
+)
+AM_CONDITIONAL(EC_DBG_IF, test "x$dbg" = x1)
+AC_SUBST([EC_DBG_IF],${dbg})
+
+#------------------------------------------------------------------------------
 
 AC_CONFIG_FILES([
-        Makefile 
-        master/Makefile 
-        devices/Makefile 
+        Makefile
+        master/Makefile
+        devices/Makefile
         script/Makefile
         include/Makefile
         examples/mini/Makefile