configure.ac
changeset 506 ca528bb97448
parent 494 178b1b43a88c
child 507 4687f9d8254e
--- a/configure.ac	Mon Dec 18 18:10:52 2006 +0000
+++ b/configure.ac	Mon Jan 01 14:58:55 2007 +0000
@@ -53,7 +53,10 @@
 if test -r ${sourcedir}/.kernelrelease; then
     kernelrelease=`cat $sourcedir/.kernelrelease`
 elif test -r ${sourcedir}/include/linux/version.h; then
-    hdr=$sourcedir/include/linux/version.h
+    hdr=$sourcedir/include/linux/utsrelease.h
+    if ! test -r $hdr; then
+        hdr=$sourcedir/include/linux/version.h
+    fi
     kernelrelease=`grep UTS_RELEASE $hdr | cut -d " " -f 3- | tr -d \"`
 fi