configure.ac
changeset 2035 72a4e043e67d
parent 2028 55854f070c4a
child 2045 ff2a13a4603c
--- a/configure.ac	Thu Jan 06 12:47:20 2011 +0100
+++ b/configure.ac	Thu Jan 06 13:11:21 2011 +0100
@@ -536,30 +536,6 @@
     AC_DEFINE([EC_REGALIAS], [1], [Read alias adresses from register])
 fi
 
-#------------------------------------------------------------------------------
-# use mutexes instead of semaphores
-#------------------------------------------------------------------------------
-
-AC_ARG_ENABLE([mutex],
-    AS_HELP_STRING([--enable-mutex],
-                   [Use mutex instead of semaphores for mutual exclusion (default: no)]),
-    [
-        case "${enableval}" in
-            yes) mutex=1
-                ;;
-            no) mutex=0
-                ;;
-            *) AC_MSG_ERROR([Invalid value for --enable-mutex])
-                ;;
-        esac
-    ],
-    [mutex=0]
-)
-
-if test "x${mutex}" = "x1"; then
-    AC_DEFINE([EC_USE_MUTEX], [1], [Use mutex for mutual exclusion])
-fi
-
 
 #------------------------------------------------------------------------------
 # Command-line tool