configure.ac
changeset 1773 5371f3e5f6a1
parent 1567 1babaa430b7b
child 1809 586be70ff70a
--- a/configure.ac	Wed Jan 13 16:39:56 2010 +0100
+++ b/configure.ac	Tue Jan 19 15:15:57 2010 +0100
@@ -475,6 +475,30 @@
 fi
 
 #------------------------------------------------------------------------------
+# High-resolution timer support
+#------------------------------------------------------------------------------
+
+AC_ARG_ENABLE([hrtimer],
+    AS_HELP_STRING([--enable-hrtimer],
+                   [Use high-resolution timer for scheduling (default: no)]),
+    [
+        case "${enableval}" in
+            yes) hrtimer=1
+                ;;
+            no) hrtimer=0
+                ;;
+            *) AC_MSG_ERROR([Invalid value for --enable-hrtimer])
+                ;;
+        esac
+    ],
+    [hrtimer=0]
+)
+
+if test "x${hrtimer}" = "x1"; then
+    AC_DEFINE([EC_USE_HRTIMER], [1], [Use hrtimer for scheduling])
+fi
+
+#------------------------------------------------------------------------------
 # Command-line tool
 #-----------------------------------------------------------------------------