configure.ac
branchredundancy
changeset 2295 4e4c018573c0
parent 2133 74dbd0b7d6aa
child 2309 b0ddf0ea0a60
--- a/configure.ac	Fri Oct 28 13:07:54 2011 +0200
+++ b/configure.ac	Fri Nov 04 12:21:09 2011 +0100
@@ -659,6 +659,31 @@
 AC_SUBST(ENABLE_TTY,[$tty])
 
 #------------------------------------------------------------------------------
+# Slave identification wildcards
+#------------------------------------------------------------------------------
+
+AC_ARG_ENABLE([wildcards],
+    AS_HELP_STRING([--enable-wildcards],
+                   [Enable vendor ID / product code wildcards (default: no)]),
+    [
+        case "${enableval}" in
+            yes) wildcards=1
+                ;;
+            no) wildcards=0
+                ;;
+            *) AC_MSG_ERROR([Invalid value for --enable-wildcards])
+                ;;
+        esac
+    ],
+    [wildcards=0]
+)
+
+if test "x${wildcards}" = "x1"; then
+    AC_DEFINE([EC_IDENT_WILDCARDS], [1],
+        [Use vendor id / product code wildcards])
+fi
+
+#------------------------------------------------------------------------------
 
 AC_CONFIG_FILES([
         Doxyfile