configure.ac
changeset 2635 42b62867574d
parent 2617 559f2f9c5b08
--- a/configure.ac	Fri Jan 22 10:11:58 2016 +0100
+++ b/configure.ac	Fri Jan 22 13:09:43 2016 +0100
@@ -820,6 +820,35 @@
 fi
 
 #------------------------------------------------------------------------------
+# Force the reference clock to OP even if unconfigured
+#------------------------------------------------------------------------------
+
+AC_MSG_CHECKING([whether to force the reference clock to OP])
+
+AC_ARG_ENABLE([refclkop],
+    AS_HELP_STRING([--enable-refclkop],
+                   [Force reference clock to OP (default: no)]),
+    [
+        case "${enableval}" in
+            yes) refclkop=1
+                ;;
+            no) refclkop=0
+                ;;
+            *) AC_MSG_ERROR([Invalid value for --enable-refclkop])
+                ;;
+        esac
+    ],
+    [refclkop=0]
+)
+
+if test "x${refclkop}" = "x1"; then
+    AC_DEFINE([EC_REFCLKOP], [1], [Force refclk to OP])
+    AC_MSG_RESULT([yes])
+else
+    AC_MSG_RESULT([no])
+fi
+
+#------------------------------------------------------------------------------
 # Command-line tool
 #-----------------------------------------------------------------------------