Makefile.am
changeset 2589 2b9c78543663
parent 2054 3417bbc4ad2f
child 2623 ae24ede76e16
--- a/Makefile.am	Thu Sep 06 14:21:02 2012 +0200
+++ b/Makefile.am	Mon Nov 03 15:20:05 2014 +0100
@@ -20,7 +20,7 @@
 #  Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
 #
 #  ---
-#  
+#
 #  The license mentioned above concerns the source code only. Using the
 #  EtherCAT technology and brand is only permitted in compliance with the
 #  industrial property and similar rights of Beckhoff Automation GmbH.
@@ -30,10 +30,13 @@
 ACLOCAL_AMFLAGS = -I m4
 
 SUBDIRS = \
-    devices \
-    include \
-    master \
-    script
+	include \
+	script
+
+if ENABLE_KERNEL
+SUBDIRS += devices
+SUBDIRS += master
+endif
 
 if BUILD_TOOL
 SUBDIRS += tool
@@ -47,23 +50,18 @@
 SUBDIRS += tty
 endif
 
-if ENABLE_RTDM
-SUBDIRS += rtdm
-endif
-
 # userspace example depends on lib/
 SUBDIRS += examples
 
 DIST_SUBDIRS = \
-    devices \
-    examples \
-    include \
-    lib \
-    m4 \
-    master \
-    script \
-    tool \
-	rtdm \
+	devices \
+	examples \
+	include \
+	lib \
+	m4 \
+	master \
+	script \
+	tool \
 	tty
 
 noinst_HEADERS = \