configure.ac
branchstable-1.3
changeset 1745 07fd94c5119d
parent 1744 7bc131b92039
child 1746 72e7507b3f1b
--- a/configure.ac	Fri Aug 10 15:27:08 2007 +0000
+++ b/configure.ac	Thu Sep 13 11:08:46 2007 +0000
@@ -3,7 +3,7 @@
 #------------------------------------------------------------------------------
 
 AC_PREREQ(2.59)
-AC_INIT([ethercat],[1.3.0],[fp@igh-essen.com])
+AC_INIT([ethercat],[1.3.1],[fp@igh-essen.com])
 AC_CONFIG_AUX_DIR([autoconf])
 AM_INIT_AUTOMAKE([-Wall -Werror dist-bzip2])
 AC_PREFIX_DEFAULT([/opt/etherlab])
@@ -414,6 +414,31 @@
 AM_CONDITIONAL(ENABLE_DUMMY, test "x$dummy" = "x1")
 
 #------------------------------------------------------------------------------
+# Ethernet-over-EtherCAT support
+#------------------------------------------------------------------------------
+
+AC_ARG_ENABLE([eoe],
+    AS_HELP_STRING([--enable-eoe],
+                   [Enable EoE support (default: yes)]),
+    [
+        case "${enableval}" in
+            yes) eoe=1
+                ;;
+            no) eoe=0
+                ;;
+            *) AC_MSG_ERROR([Invalid value for --enable-eoe])
+                ;;
+        esac
+    ],
+    [eoe=1]
+)
+
+if test "x${eoe}" = "x1"; then
+    AC_DEFINE([EC_EOE], [1], [EoE support enabled])
+fi
+AM_CONDITIONAL(ENABLE_EOE, test "x$eoe" = "x1")
+
+#------------------------------------------------------------------------------
 
 # Create config.kbuild
 
@@ -433,6 +458,7 @@
 MSR_DIR := "${msrdir}"
 ENABLE_DEBUG_IF := ${dbg}
 ENABLE_DUMMY := ${dummy}
+ENABLE_EOE := ${eoe}
 EOF
 
 #------------------------------------------------------------------------------