equal
deleted
inserted
replaced
1 #!/usr/bin/make -f |
1 #!/usr/bin/make -f |
2 # -*- makefile -*- |
2 # -*- makefile -*- |
3 # Sample debian/rules that uses debhelper. |
|
4 # |
|
5 # This file was originally written by Joey Hess and Craig Small. |
|
6 # As a special exception, when this file is copied by dh-make into a |
|
7 # dh-make output file, you may use that output file without restriction. |
|
8 # This special exception was added by Craig Small in version 0.37 of dh-make. |
|
9 # |
|
10 # Modified to make a template file for a multi-binary package with separated |
|
11 # build-arch and build-indep targets by Bill Allombert 2001 |
|
12 |
3 |
13 # Uncomment this to turn on verbose mode. |
4 # Uncomment this to turn on verbose mode. |
14 export DH_VERBOSE=1 |
5 export DH_VERBOSE=1 |
15 |
6 |
16 # This has to be exported to make some magic below work. |
7 # This has to be exported to make some magic below work. |
28 #### CONFIG.STATUS #### |
19 #### CONFIG.STATUS #### |
29 dh_testdir |
20 dh_testdir |
30 |
21 |
31 # Add here commands to configure the package. |
22 # Add here commands to configure the package. |
32 cp debian/control-$(shell echo $(CAN_INTERFACE)) debian/control; \ |
23 cp debian/control-$(shell echo $(CAN_INTERFACE)) debian/control; \ |
33 ./configure --can=$(shell echo $(CAN_INTERFACE)) --prefix=/usr |
24 ./configure --can=$(shell echo $(CAN_INTERFACE)) --prefix=/usr --wx=0 |
34 |
25 |
35 build: build-indep |
26 build: build-indep |
36 |
27 |
37 build-indep: build-indep-stamp |
28 build-indep: build-indep-stamp |
38 |
29 |
93 binary-common: |
84 binary-common: |
94 #### BINARY-COMMON #### |
85 #### BINARY-COMMON #### |
95 dh_testdir |
86 dh_testdir |
96 dh_testroot |
87 dh_testroot |
97 dh_installchangelogs CHANGES |
88 dh_installchangelogs CHANGES |
98 dh_installdocs |
89 # dh_installdocs |
99 # dh_installexamples |
90 # dh_installexamples |
100 # dh_installmenu |
91 # dh_installmenu |
101 # dh_installdebconf |
92 # dh_installdebconf |
102 # dh_installlogrotate |
93 # dh_installlogrotate |
103 # dh_installemacsen |
94 # dh_installemacsen |