setup.py
changeset 148 a083d4a94bd3
child 149 189ebdde3eb9
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Tue Jan 15 10:51:18 2008 +0100
@@ -0,0 +1,38 @@
+import os,sys,glob
+from distutils.core import setup
+
+
+install_dir=os.path.join("LOLITech","PlcOpenEditor")
+
+data_files=[]
+os.getcwd()
+os.chdir(os.getcwd())
+
+def generate(base_dir):
+    listfile=[]
+    if base_dir == "":
+        directory = "."
+    else:
+        directory = base_dir
+    data_files.append((os.path.join(install_dir, base_dir), listfile))
+
+    for element in os.listdir(directory):
+        element_path=os.path.join(base_dir, element)
+        if os.path.isdir(element_path):
+            generate(element_path)
+        elif os.path.isfile(element_path):
+            listfile.append(element_path)
+
+generate("")
+
+
+setup(name='PlcOpenEditor', # Name of the executable
+      version='0.1', # Version
+      description='Editor for the 5 of the IEC-61131-3 languages', #description
+      author='Edouard Tisserant, Laurent Bessard',
+      author_email='laurent.bessard@lolitech.fr',
+      url='http://www.beremiz.org',
+      license='GPL',
+      scripts=['plcopeneditor_postinst.py'],
+      data_files=data_files, # Add files to install
+)
\ No newline at end of file