setup.py
changeset 454 762497a95b7a
parent 453 d01e025b868d
child 456 dc379f8db18d
--- a/setup.py	Wed Oct 28 13:51:32 2009 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,38 +0,0 @@
-import os,sys,glob
-from distutils.core import setup
-
-
-install_dir=os.path.join("LOLITech","plcopeneditor")
-
-data_files=[]
-os.getcwd()
-os.chdir(os.getcwd())
-
-def generate(base_dir):
-    listfile=[]
-    if base_dir == "":
-        directory = "."
-    else:
-        directory = base_dir
-    data_files.append((os.path.join(install_dir, base_dir), listfile))
-
-    for element in os.listdir(directory):
-        element_path=os.path.join(base_dir, element)
-        if os.path.isdir(element_path):
-            generate(element_path)
-        elif os.path.isfile(element_path):
-            listfile.append(element_path)
-
-generate("")
-
-
-setup(name='PlcOpenEditor', # Name of the executable
-      version='0.1', # Version
-      description='Editor for the 5 of the IEC-61131-3 languages', #description
-      author='Edouard Tisserant, Laurent Bessard',
-      author_email='laurent.bessard@lolitech.fr',
-      url='http://www.beremiz.org',
-      license='GPL',
-      scripts=['plcopeneditor_postinst.py'],
-      data_files=data_files, # Add files to install
-)
\ No newline at end of file