greg@106: #!/usr/bin/make -f
greg@106: # -*- makefile -*-
greg@106: # Sample debian/rules that uses debhelper.
greg@106: # This file was originally written by Joey Hess and Craig Small.
greg@106: # As a special exception, when this file is copied by dh-make into a
greg@106: # dh-make output file, you may use that output file without restriction.
greg@106: # This special exception was added by Craig Small in version 0.37 of dh-make.
greg@106: 
greg@106: # Uncomment this to turn on verbose mode.
greg@106: export DH_VERBOSE=1
greg@106: 
greg@106: CFLAGS = -Wall -g
greg@106: 
greg@106: ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
greg@106: 	CFLAGS += -O0
greg@106: else
greg@106: 	CFLAGS += -O2
greg@106: endif
greg@106: 
greg@106: build: build-stamp
greg@106: 
greg@171: build-stamp:
greg@106: 	dh_testdir
greg@106: 	# Add here commands to compile the package.
greg@106: 	$(MAKE)
greg@106: 	touch $@
greg@106: 
greg@171: clean:
greg@106: 	dh_testdir
greg@106: 	dh_testroot
greg@171: 	rm -f build-stamp
greg@106: 
greg@106: 	# Add here commands to clean up after the build process.
greg@106: 	-$(MAKE) clean
greg@106: 
greg@106: 	dh_clean 
greg@106: 
greg@106: install: build
greg@106: 	dh_testdir
greg@106: 	dh_testroot
greg@106: 	dh_clean -k 
greg@106: 	dh_installdirs
greg@106: 
greg@106: 	# Add here commands to install the package into debian/matiec.
greg@171: 	#$(MAKE) INSTALL_PREDIR=$(CURDIR)/debian/matiec/usr INSTALL_BINDIR=/bin IECLIBDIR=/lib install	
greg@106: 	
greg@171: 	# Add here commands to install the package into debian/beremiz.
greg@171: 	mkdir -p $(CURDIR)/debian/matiec/usr/share/matiec
greg@171: 	
greg@171: 	cp -a lib $(CURDIR)/debian/matiec/usr/share/matiec
greg@171: 	cp iec2c $(CURDIR)/debian/matiec/usr/share/matiec
greg@106: 
greg@106: # Build architecture-independent files here.
greg@106: binary-indep: build install
greg@106: # We have nothing to do by default.
greg@106: 
greg@106: # Build architecture-dependent files here.
greg@106: binary-arch: build install
greg@106: 	dh_testdir
greg@106: 	dh_testroot
greg@213: #	dh_installchangelogs 
greg@213: #	dh_installdocs
greg@213: #	dh_installexamples
greg@106: #	dh_install
greg@106: #	dh_installmenu
greg@106: #	dh_installdebconf	
greg@106: #	dh_installlogrotate
greg@106: #	dh_installemacsen
greg@106: #	dh_installpam
greg@106: #	dh_installmime
greg@106: #	dh_python
greg@106: #	dh_installinit
greg@106: #	dh_installcron
greg@106: #	dh_installinfo
greg@213: #	dh_installman
greg@106: 	dh_link
greg@106: 	dh_strip
greg@106: 	dh_compress
greg@106: 	dh_fixperms
greg@106: #	dh_perl
greg@106: #	dh_makeshlibs
greg@106: 	dh_installdeb
greg@106: 	dh_shlibdeps
greg@106: 	dh_gencontrol
greg@106: 	dh_md5sums
greg@106: 	dh_builddeb
greg@106: 
greg@106: binary: binary-indep binary-arch
greg@171: .PHONY: build clean binary-indep binary-arch binary install