Makefile.am
changeset 370 f3cec8694f65
parent 369 569e7d9e2406
--- a/Makefile.am	Thu Aug 25 08:56:28 2011 +0200
+++ b/Makefile.am	Thu Aug 25 17:22:44 2011 +0200
@@ -6,6 +6,9 @@
 
 ACLOCAL_AMFLAGS=-I config
 
+HGVERSION= $(shell hg -R $(top_srcdir) parents --template '{node|short}' 2> /dev/null || grep node $(top_srcdir)/.hg_archival.txt 2> /dev/null || true )
+AM_CXXFLAGS += -DHGVERSION="\"${HGVERSION}\""
+
 iec2c_LDADD = stage1_2/libstage1_2.a \
 	stage3/libstage3.a \
 	stage4/generate_c/libstage4_c.a \