configure.ac
changeset 1072 2dc67df52e59
parent 1066 29735e347716
--- a/configure.ac	Fri Apr 20 17:38:09 2018 +0100
+++ b/configure.ac	Fri Apr 20 17:40:29 2018 +0100
@@ -28,8 +28,7 @@
 AC_PROG_AWK
 
 # Check bison version, we need a version great or equal than 2.4 to build matiec.
-version_bison="$(bison --version | sed q | cut -d' ' -f4)"
-version_bison=${version_bison:0:3}
+version_bison="$(bison --version | sed q | cut -d' ' -f4 | cut -d'.' -f1,2 )"
 
 AS_IF([awk -v ver="$version_bison" 'BEGIN { if (ver < 2.4) exit 1; }'],
 	[have_bison_correct=yes], [have_bison_correct=no])