stage1_2/Makefile.am
changeset 354 0f24db96b519
parent 353 17bffb57a8c5
child 369 569e7d9e2406
--- a/stage1_2/Makefile.am	Fri Jul 29 16:08:40 2011 +0100
+++ b/stage1_2/Makefile.am	Fri Aug 19 17:33:57 2011 +0100
@@ -1,16 +1,20 @@
 include ../common.mk
 
+
+
+
+AM_YFLAGS = -d
+AM_LFLAGS = -o$(LEX_OUTPUT_ROOT).c
+
+
+# Make sure this header file is generated first (by bison), as it is included
+# by other C++ code that will also be compiled.
+BUILT_SOURCES = iec_bison.h
+
 lib_LIBRARIES = libstage1_2.a
-
-iec.y.cc: iec.y
-	$(YACC) -d -v -o iec.y.cc iec.y
-
-iec.flex.cc: iec.flex
-	$(LEX) -o iec.flex.cc iec.flex
-
 libstage1_2_a_SOURCES = \
-	iec.flex.cc \
-	iec.y.cc \
+	iec_flex.ll \
+	iec_bison.yy \
 	stage1_2.cc 
 
 libstage1_2_a_CPPFLAGS =  -DDEFAULT_LIBDIR='"lib"' -I../../absyntax