debian/canfestival-virtual.postinst
author Edouard Tisserant
Thu, 24 Jan 2019 13:53:01 +0100
changeset 808 de1fc3261f21
parent 579 3126da40d469
permissions -rwxr-xr-x
Adding -fPIC isn't necessary of xeno-config is set correctly. Backed out changeset b9f1fcda7d30
#!/bin/sh
# postinst script for canfestival
#
# see: dh_installdeb(1)

set -e

DLL_LIST=
CF_CONFIG=/usr/share/CanFestival-3/objdictgen/canfestival_config.py
CF_CONFIG_TEMP=/usr/share/CanFestival-3/objdictgen/canfestival_config_ori.py

case "$1" in
    configure)
    ldconfig
    
	# Find canfestival driver library in /usr/lib
	cd /usr/lib
	for file in libcanfestival_can*
	do
		DLL_LIST="'$file',""$DLL_LIST"
	done
	
	# copy template config and add the DLL_LIST 
	# do this to display available canfestival plugin list choice in beremiz
	cat $CF_CONFIG_TEMP > $CF_CONFIG
	echo "DLL_LIST=[$DLL_LIST]" >> $CF_CONFIG
	;;
	
    abort-upgrade|abort-remove|abort-deconfigure)
    ;;

    *)
        echo "postinst called with unknown argument \`$1'" >&2
        exit 1
    ;;
esac

# dh_installdeb will replace this with shell code automatically
# generated by other debhelper scripts.

#DEBHELPER#

exit 0