debian/patches/02-makefile_examples.dpatch
author etisserant
Fri, 01 Feb 2008 18:06:55 +0100
changeset 378 d2abf6c8c27b
parent 346 59dbdcc99264
permissions -rwxr-xr-x
As requested long ago, added CoData* parameter to all this applications callback, let application designer use identical callback for multiple nodes, and reduce source code length.

Concerned callbacks :

initialisation
preOperational
operational
stopped
heartbeatError
post_sync
post_TPDO
post_SlaveBootup
storeODSubIndex
post_emcy
#! /bin/sh /usr/share/dpatch/dpatch-run
## 02-makefile_examples.dpatch by  <lolitech@lolitech-desktop>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: No description.

@DPATCH@
diff -urNad canfestival-3~/examples/Makefile.in canfestival-3/examples/Makefile.in
--- canfestival-3~/examples/Makefile.in	2007-10-11 09:13:05.000000000 +0200
+++ canfestival-3/examples/Makefile.in	2007-11-21 10:22:39.000000000 +0100
@@ -30,8 +30,8 @@
 
 ifeq ($(TARGET),unix)
 	$(MAKE) -C TestMasterSlave $@
-#	$(MAKE) -C DS401_Master $@
-#	$(MAKE) -C DS401_Slave_Gui $@
+	$(MAKE) -C DS401_Master $@
+	$(MAKE) -C DS401_Slave_Gui $@
 	$(MAKE) -C TestMasterMicroMod $@
 endif
 
@@ -49,8 +49,8 @@
 
 ifeq ($(TARGET),unix)
 	$(MAKE) -C TestMasterSlave $@
-#	$(MAKE) -C DS401_Master $@
-#	$(MAKE) -C DS401_Slave_Gui $@
+	$(MAKE) -C DS401_Master $@
+	$(MAKE) -C DS401_Slave_Gui $@
 	$(MAKE) -C TestMasterMicroMod $@
 endif
 
@@ -70,15 +70,15 @@
 install:
 ifeq ($(TARGET),unix)
 	$(MAKE) -C TestMasterSlave $@
-#	$(MAKE) -C DS401_Master $@
-#	$(MAKE) -C DS401_Slave_Gui $@
+	$(MAKE) -C DS401_Master $@
+	$(MAKE) -C DS401_Slave_Gui $@
 	$(MAKE) -C TestMasterMicroMod $@
 endif
 
 uninstall:
 ifeq ($(TARGET),unix)
 	$(MAKE) -C TestMasterSlave $@
-#	$(MAKE) -C DS401_Master $@
-#	$(MAKE) -C DS401_Slave_Gui $@
+	$(MAKE) -C DS401_Master $@
+	$(MAKE) -C DS401_Slave_Gui $@
 	$(MAKE) -C TestMasterMicroMod $@
 endif