patch from Stefan Kratochwil <entwicklung@inovel.de> : canfestival-3-fm3_698.patch
Bug:
If an object dictionary entry was requested whose size exceeds
SDO_MAX_LENGTH_TRANSFERT, the memcpy() call at line 139 of objacces.c overwrites
the memory after *pDestData which causes stack corruption.
-> Bugfix:
The bug was corrected by size checking the requested data. An 'Out of
memory' error message will be generated if the requested data exceeds
SDO_MAX_LENGTH_TRANSFERT.
Additional changes:
Added dynamic buffer allocation for the SDO transfer. This feature can be used
if SDO_DYNAMIC_BUFFER_ALLOCATION is defined in config.h. The size of the
dynamically allocated buffer is controlled with
SDO_DYNAMIC_BUFFER_ALLOCATION_SIZE.
-> Note:
This change removes the detection of OD_LENGTH_DATA_INVALID errors!
Source: canfestival
Section: devel
Priority: standard
Maintainer: edouard <edouard.tisserant@gmail.com>
Build-Depends: debhelper (>= 5)
Standards-Version: 3.7.2
Package: canfestival
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
Description: <insert up to 60 chars description>
Package: canfestival-devel
Architecture: all
Description: Canfestival library
This package contains the CanFestival library for unix platform.
Package: canfestival-examples
Architecture: all
Description: Program's Examples for canfestival
This package contains some test programs you can use as example
for your own developments.
- TestMasterSlave : Two CanOpen nodes in the same process
- TestMasterMicromod : A CanOpen master that control a peak MicroMod module
- DS401_Master : Master Node for the DS401_Slave_Gui
- DS401_Slave_Gui : Simulate an I/O module with GUI
Package: canfestival-doc
Architecture: all
Description: Documentation for canfestival
Package: canfestival-${CAN_INTERFACE}
Architecture: all
Description: Can Driver Interface for Peak Driver
Package: canfestival-objdictedit
Architecture: all
Depends: python-wxgtk2.8, xpdf
Description: A CanOpen Node Editor
Objdictedit, the Object Dictionary Editor, is a WxPython based GUI that is used to
create the C file needed to create a new CanOpen node.