debian/canfestival-virtual.postinst
changeset 531 f912f8d26e98
child 533 4d50417dab22
equal deleted inserted replaced
530:458418d7e10f 531:f912f8d26e98
       
     1 #!/bin/sh
       
     2 # postinst script for canfestival
       
     3 #
       
     4 # see: dh_installdeb(1)
       
     5 
       
     6 set -e
       
     7 
       
     8 # summary of how this script can be called:
       
     9 #        * <postinst> `configure' <most-recently-configured-version>
       
    10 #        * <old-postinst> `abort-upgrade' <new version>
       
    11 #        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
       
    12 #          <new-version>
       
    13 #        * <postinst> `abort-remove'
       
    14 #        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
       
    15 #          <failed-install-package> <version> `removing'
       
    16 #          <conflicting-package> <version>
       
    17 # for details, see http://www.debian.org/doc/debian-policy/ or
       
    18 # the debian-policy package
       
    19 
       
    20 DLL_LIST=
       
    21 CF_CONFIG=/usr/share/CanFestival-3/objdictgen/canfestival_config.py
       
    22 CF_CONFIG_TEMP=/usr/share/CanFestival-3/objdictgen/canfestival_config_ori.py
       
    23 case "$1" in
       
    24     configure)
       
    25     ldconfig
       
    26     cd /usr/lib
       
    27     DLL_LIST=
       
    28 	FILES=
       
    29 	for file in libcanfestival_can*
       
    30 	do
       
    31 		DLL_LIST="$file,""$DLL_LIST"
       
    32 	done
       
    33 	cat $CF_CONFIG_TEMP > $CF_CONFIG
       
    34 	echo "DLL_LIST=[$DLL_LIST]" >> $CF_CONFIG
       
    35 	;;
       
    36 	
       
    37     abort-upgrade|abort-remove|abort-deconfigure)
       
    38     ;;
       
    39 
       
    40     *)
       
    41         echo "postinst called with unknown argument \`$1'" >&2
       
    42         exit 1
       
    43     ;;
       
    44 esac
       
    45 
       
    46 # dh_installdeb will replace this with shell code automatically
       
    47 # generated by other debhelper scripts.
       
    48 
       
    49 #DEBHELPER#
       
    50 
       
    51 exit 0
       
    52 
       
    53