3 # |
3 # |
4 # see: dh_installdeb(1) |
4 # see: dh_installdeb(1) |
5 |
5 |
6 set -e |
6 set -e |
7 |
7 |
8 # summary of how this script can be called: |
|
9 # * <postinst> `configure' <most-recently-configured-version> |
|
10 # * <old-postinst> `abort-upgrade' <new version> |
|
11 # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
|
12 # <new-version> |
|
13 # * <postinst> `abort-remove' |
|
14 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
|
15 # <failed-install-package> <version> `removing' |
|
16 # <conflicting-package> <version> |
|
17 # for details, see http://www.debian.org/doc/debian-policy/ or |
|
18 # the debian-policy package |
|
19 |
|
20 DLL_LIST= |
8 DLL_LIST= |
21 CF_CONFIG=/usr/share/CanFestival-3/objdictgen/canfestival_config.py |
9 CF_CONFIG=/usr/share/CanFestival-3/objdictgen/canfestival_config.py |
22 CF_CONFIG_TEMP=/usr/share/CanFestival-3/objdictgen/canfestival_config_ori.py |
10 CF_CONFIG_TEMP=/usr/share/CanFestival-3/objdictgen/canfestival_config_ori.py |
|
11 |
23 case "$1" in |
12 case "$1" in |
24 configure) |
13 configure) |
25 ldconfig |
14 ldconfig |
26 cd /usr/lib |
15 |
27 DLL_LIST= |
16 # Find canfestival driver library in /usr/lib |
28 FILES= |
17 cd /usr/lib |
29 for file in libcanfestival_can* |
18 for file in libcanfestival_can* |
30 do |
19 do |
31 DLL_LIST="'$file',""$DLL_LIST" |
20 DLL_LIST="'$file',""$DLL_LIST" |
32 done |
21 done |
|
22 |
|
23 # copy template config and add the DLL_LIST |
|
24 # do this to display available canfestival plugin list choice in beremiz |
33 cat $CF_CONFIG_TEMP > $CF_CONFIG |
25 cat $CF_CONFIG_TEMP > $CF_CONFIG |
34 echo "DLL_LIST=[$DLL_LIST]" >> $CF_CONFIG |
26 echo "DLL_LIST=[$DLL_LIST]" >> $CF_CONFIG |
35 ;; |
27 ;; |
36 |
28 |
37 abort-upgrade|abort-remove|abort-deconfigure) |
29 abort-upgrade|abort-remove|abort-deconfigure) |